Resolved
All systems are operating normally now.
Monitoring
It looks like a temporary backend infrastructure issue led to an escalation of request volume, as the portal and app continued trying to request data from the reporting server. This made it difficult for the server to recover on its own, so we added more resources to accommodate, and everything began to stabilize.
Identified
It looks like a temporary backend infrastructure issue led to an escalation of request volume, as the portal and app continued trying to request data from the reporting server. This made it difficult for the server to recover on its own, so we added more resources to accommodate, and everything began to stabilize.
Identified
We've identified the service that started failing, and we are making updates to mitigate.
Investigating
We're seeing some backend timeouts loading facility and room data and are currently investigating.