Resolved
We're still awaiting a root cause analysis from Azure, but we haven't observed any repeat disruptions since the last update, and we are marking the incident resolved.
Monitoring
We have readied a workaround on our end to mitigate issues caused by the Azure disruption, but no ongoing issues have been observed for about 25 minutes now. We are awaiting a status update from Azure, and we will share more detail if anything changes or when we know more.
Identified
Microsoft have reported service impacts affecting part of the Growlink backend in our Azure region. They're actively addressing the problem, but we're seeing intermittent issues loading Growlink apps. In the meantime, we are investigating any potential workarounds we can implement on our end.